stephenbrooks.orgForumMuon1GeneralProblem with 4.42c on an AMD64
Username: Password:
Search site:
Subscribe to thread via RSS
2006-04-24 20:41:55
Has anyone encountered a problem with muon1 on an AMD64 that causes muon1 to halt if the results.dat file gets too big?

I have several AMD machines and two P4 machines.  I have a results.dat file that varies between 60,000 and 100,000 results.

muon1 runs fine with this many results on all my machines but the AMD64. I even tried reloading the machine with XP Pro and I still have the same problem even on a fresh install.

I even pulled memory chips from a working machine and plugged them into the AMD64 --- no joy... same error message.

I need to trim the results.dat file down to 40,000 for it to run without errors.  Anything over 60,000 causes an exception error once the program is done loading the results into memory.

I only have one AMD64 machine and was wondering if anyone else with an AMD64 has encountered something like this.

Stephen Brooks
2006-04-26 02:53:35
What is the RAM usage of Muon1 with that size of results.dat under the two systems?
2006-04-26 10:02:02
Actually, I did get the process to finally fail on my Athlons, Semprons and P4s.
Each of these machines contains at least 2GB of RAM.

This results.dat file contains 81,088 results with a file size of 174MB.
The memory requirements are appx 700MB+ of active memory.

Are there memory limits on v442c?
Stephen Brooks
2006-04-28 04:00:58
I was just wondering if you ran out of RAM - right now larger results.dat need to be "pruned" occasionally to stop this happening.
: contact : - - -
E-mail: sbstrudel characterstephenbrooks.orgTwitter: stephenjbrooksMastodon: strudel charactersjbstrudel RSS feed

Site has had 25366403 accesses.