stephenbrooks.orgForumMuon1Bug Reportsver 4.43a bugs?
Username: Password:
Search site:
Subscribe to thread via RSS
2006-05-20 21:29:49
Sorry for the double post.

Two possible bugs for 4.43a:

1. Start graphical client.
Escape right away, it autosaves.
Now start it again, the client goes totally crazy from now on.  It seems autosave isn't
loaded correctly.

2. Start graphical or commandline client.
There is one line showing:
"Loading 'samplefiles\DcayRotB.txt' ... File empty"
Obvoiusly the client tries to load a wrong filename, it must be 'samplefiles\DcayRotB_100.txt' I think.

Sorry for poor English.

Stephen Brooks
2006-05-21 22:09:52
I can check the autosave thing tomorrow.  The other might be OK if the client hadn't downloaded that particular sample file yet.
Stephan Hermens[RKN]
2006-05-21 23:41:28
The samplefiles are downloaded and saved as "samplefiles\{$latticename}_100.txt", but later opened as "samplefiles\{$latticename}.txt".
2006-05-21 23:56:31
comment to 1. The particles went right trough the Solenoid's walls, there seemed to exist no boundaries anymore.

comment to 2. Yes, the '_100' is missing.

Thanks for replying.

Stephen Brooks
2006-05-22 23:47:33
Errrr if this is true, it would explain the slow progress in some of the recent optimisations
Stephen Brooks
2006-05-23 00:57:41
Timer on this board seems a bit wrong, it should be 1800 BST

Didn't get the bugs today, will try tomorrow.
2006-05-23 14:47:26
Yeah, something is wrong.  I keep geting very poor results (mostly negative) for ChicanelinacB and PhaserotC, seems like there is no sample file (but it is)....This is since I upgraded to v.4.43. And there is no convergence in DecayrotB.
Stephen Brooks
2006-05-23 18:53:15
OK, fixed (version info), I hope.
Stephan Hermens[RKN]
2006-05-24 01:05:06
The samplefiles are downloaded to "samplefiles\{$latticename}.txt" now, but when using the default .bin download they are not decoded.  So I get:
"Loading 'samplefiles\DecayRotB.txt'... OK (0 results)"
And by the way: When the decoding worked (in 4.43 and 4.43a) I noticed that all results had a percentage of 0.0, which leads to a lot of rechecking of the first designs that are tested in a clean install.
2006-05-24 07:44:23
Duh.. cost a bit to understand how this forum works, I didn't recognize that it was set up until now.

I found the 0% samplefiles 2 days ago and compiled a little results.dat for decayrotb with 3 good results only, that's why I've spammed the sampleresults for them now with mine

However my results.dat was later again filled with negative results and no good results left, so I did it just again together with the new version, hoping that it will continue now in order as previous versions.
2006-05-24 12:33:30
4.43b doesn't want to work for me...just using CPU but no results.  And on my Athlom MP it used one CPU only.  For PhaserotC I went back to version 4.42c and now it produces results as expected (no negative ones) from the same .dat file 4.43 produced negative ones mostly.
Stephen Brooks
2006-05-24 12:39:18
Download the debug EXE and run it if you get crashes.  Then tell me what the error box said.
Stephen Brooks
2006-05-24 18:40:32
fixed, v4.43c / version info
2006-05-25 01:46:20
Now working as intended, thanks for fixing.

2006-06-06 11:18:00
It seems all 4.43 versions don't support multithreading anymore.  No matter the amount of threads I set in the config file, it only generates 1 thread.  I tested with 4.43a, b and c and they all have the same behaviour.  All worked fine with 4.42 and earlier.
Setup is a genuine dual-cpu sytem, not dual-core or hyperthreading.
Stephen Brooks
2006-06-06 11:21:23
Make sure there isn't a "duplicate" entry in the config file (another entry saying "Threads:" etc.).  Try also a clean install, just in case there is something in your current directory making it go bad.  Here I have 4.43c running with 4 threads.
2006-06-06 19:24:13
Hm seems like something went wrong during replying..
Anyways, it's all working fine now; took a clean install though, the config file had no duplicates.
: contact : - - -
E-mail: sbstrudel characterstephenbrooks.orgTwitter: stephenjbrooksMastodon: strudel charactersjbstrudel RSS feed

Site has had 21440133 accesses.