stephenbrooks.orgForumMuon1Bug ReportsBad checksums
Username: Password:
Search site:
Subscribe to thread via RSS
2004-11-29 17:37:49
Ok I have the client running in Linux via Wine (muon1_background.exe) and it runs fine.  I can see the results.txt file buliding up.  Today I transfered the entire client directory to one of my windows machines to upload the results and when I ran the manual send, I got the following error on every single result in the results.txt file.  Is there a logical reason behind this?  Does the results.txt file have the wrong format due to Linux?  I've lost two very big results.txt files in a row from this (I have yet to be able to upload any results from the client that was running in Linux).  I do have my most recent results.txt file backed up, was hoping I could find away to get these submitted.

Reparsing results...
[WARNING] Record rejected due to bad checksum: was {7BA428C9ECC017E06A3A3880}
Continue (Y/N/These/All)?  N
[DPC] Alphen
2004-12-06 00:25:36
Yep... me 2... Frown
2004-12-06 02:04:02
I've made a samba share for the muon directory and mounted it as a network drive on my windows machine.  When I want to send results I just execute manualsend from there, i.e. I even don't stop the client running on the linux machine most times.
Stephen Brooks
2004-12-06 02:29:02
When you view it in a hex editor, what separates the lines?  I thought I'd written it so that it didn't care whether it was an 0D 0A or just an 0A, but maybe not.  Use the attached program to change UNIX text files into DOS like ones... see if that works.
2005-03-27 23:28:16
I experience the same under winXP.  About 30% of a manualsend where marked as bad bad checksum.  I managed to save the bad part of the file.  It's about 2MB only bad checksome data.  It occured without a pattern through all the original data.
I had this already a month ago with about 250k not credited, that time I missed to save the bad ones.
2006-06-07 19:12:20
I also have a problem with checksum when starting a new simulation in the screensaver mode.  Following is the message displayed.  I have been pressing 'A' for 'All' to continue...
"New Simulation"
"[Warning] Record rejected due to badchecksum: was {54D5A6B97939BE3F875A10F3}
Continue [Y/N/These/All]?  A.

I believe that this is the file in question.

1.558753,1.524178,1.511772 (1526.9 Mpts) [v4.42c] {54D5A6B97939BE3F875A10F3} <ChicaneLinacB>

Please advise as to my next course of action.

[Crunchers Inc]cswchan
2006-06-07 19:26:07
Sorry... just checked... it also occurs when running the muon1 simulation "Muon1_cmdline.bat" Windows XP Pro, AMD 2600, 1G DDR Ram version 4.4.2
Stephen Brooks
2006-06-08 03:36:39
Remove that result from your results.dat (or queue.txt) and the program should continue running without it.
2006-06-19 13:58:49
Ehm me is newby but both my fast amd machines have same.
Everytime a calculation has ended it asks to continue.
Even worse i deleted all and installed again but after some time running witout error they come back again.
With almost every result i get that message i have been running for 2 days and got the enormous amount of 617 points.
So i think something is very wrong
2006-06-19 14:23:55
Damn over the last run i have another 48 errors.
And yes i run the commandline one as well don't want all the graphics pure calc power is good enough
system 1 = Amd64 3500+, Asus A8V DLX, 300 Gb sata Wd, 1024 Mb PC4000 Dual channel memory.
system 2 = AmdX2 3800+, Gigabyte A8N Sli Pro, 4 x 300 Gb drives, 2048 Mb PC3200 Dual channel memory.

As i mentioned earlier on both systems i get loads of checksum errors but seems some are send i manually send results and got some points.
I run the latest version of muon
Stephen Brooks
2006-06-19 14:56:18
If it's causing an error on *everything*, sounds to me like some of your downloads have come back corrupted (like the lattice files or the sample files aren't right).

Incidentally, if you want it not to prompt you for that any more, pressing "A" for "all" should make it say 'yes' to every warning that comes up.
2006-06-20 09:29:50
Hmmm so how can it be possible that after i deleted everything it happens again and on both my machines have the same problem ?
Second i had done that allready because after almost every test it made it was asking this question.
The screen was filled with these Record rejected messages.
Does it affect the points you get ?  for the work done ?

Again i uninstalled and newly installed and run from scratch and again after download the work, it comes with the record warnings.  Looks like it has downloaded something different this time also : PhaseRotB and DecayRotB

2006-06-21 13:54:46
Don't know if this is related, one independent box of mine created 5 checksum results in a row just after the samplefiles were updated automatically; all were runs=5 on phaserotd, some 1400 Mpts gone.  After that 75kB of good results were send ok and no further mishaps appeared so far.

I have the bad 24kB results isolated so I send them in per e-mail and you may figure out something.
: contact : - - -
E-mail: sbstrudel characterstephenbrooks.orgTwitter: stephenjbrooksMastodon: strudel charactersjbstrudel RSS feed

Site has had 21440665 accesses.